diff mbox series

[bug#50628,084/154] gnu: Add trytond-production-routing.

Message ID 50a3748e929ed7e34279c180a023afad4e66c1b5.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-production-routing): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3936c1c5e9..e787951718 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2450,6 +2450,30 @@  set to @code{waiting}, a purchase order is created and its cost is added to
 the production.")
     (license license:gpl3+)))
 
+(define-public trytond-production-routing
+  (package
+    (name "trytond-production-routing")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production_routing" version))
+       (sha256
+        (base32 "0qypqsf36lf02wrbv7pwhg2vv7004g7c6vxd1z2aiwj58g8q7894"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production_routing"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-stock-supply-production" ,trytond-stock-supply-production)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production" ,trytond-production)))
+    (home-page "https://docs.tryton.org/projects/modules-production-routing")
+    (synopsis "Tryton module for production routing")
+    (description "The @emph{Production Routing} Tryton module defines the
+routings for production: Routing, Step and Operation.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")