diff mbox series

[bug#50628,004/154] gnu: Add python-tablib.

Message ID dc3c811fb6288b094a470a8b9287aa91ed2d571e.1631832504.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-tablib): New variable.
---
 gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

M Sept. 17, 2021, 2:15 p.m. UTC | #1
Hartmut Goebel schreef op vr 17-09-2021 om 00:52 [+0200]:
> * gnu/packages/python-xyz.scm (python-tablib): New variable.
> ---
>  gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 23a76d7727..693de6db7d 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -26645,3 +26645,49 @@ Braintree Gateway.  Braintree is a US-based payments service provider.")
>  HTML/XML from a Python program in an intuitive, lightweight, customizable and
>  pythonic way.")
>      (license license:expat)))
> +
> +(define-public python-tablib
> +  (package
> +    (name "python-tablib")
> +    (version "3.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "tablib" version))
> +       (sha256
> +       (base32 "03f1z6jq6rf67gwhbm9ma4rydm8h447a5nh5lcs5l8jg8l4aqg7q"))))
> +    (build-system python-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key tests? #:allow-other-keys)
> +             (when tests?
> +               (setenv "PYTHONPATH"
> +                       (string-append (getcwd) "/build/lib:"
> +                                      (getenv "PYTHONPATH")))
> +               (invoke "pytest")))))))
> +    (native-inputs
> +     `(("python-pandas" ,python-pandas)  ;; required for test-suite
> +       ("python-pytest" ,python-pytest)
> +       ("python-pytest-cov" ,python-pytest-cov)
> +       ("python-setuptools-scm" ,python-setuptools-scm)))
> +    (propagated-inputs
> +     `(("python-markuppy" ,python-markuppy)
> +       ("python-odfpy" ,python-odfpy)
> +       ("python-openpyxl" ,python-openpyxl)
> +       ("python-pyyaml" ,python-pyyaml)
> +       ("python-tabulate" ,python-tabulate)
> +       ("python-xlrd" ,python-xlrd)
> +       ("python-xlwt" ,python-xlwt)))
> +    (home-page "https://tablib.readthedocs.io")
> +    (synopsis "Format agnostic tabular data library")
> +    (description "is a format-agnostic tabular dataset library,
> +written in Python.  Supported [...]

Sentence is missing a subject.  If "guix show python-tablib" is run,
this would result in:

[...]
synopsis: Format agnostic tabular data library
description: is a format-agnostic tabular dataset library, written in Python. [...]

which isn't grammatical, though the meaning would be clear from context.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 23a76d7727..693de6db7d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26645,3 +26645,49 @@  Braintree Gateway.  Braintree is a US-based payments service provider.")
 HTML/XML from a Python program in an intuitive, lightweight, customizable and
 pythonic way.")
     (license license:expat)))
+
+(define-public python-tablib
+  (package
+    (name "python-tablib")
+    (version "3.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tablib" version))
+       (sha256
+       (base32 "03f1z6jq6rf67gwhbm9ma4rydm8h447a5nh5lcs5l8jg8l4aqg7q"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (setenv "PYTHONPATH"
+                       (string-append (getcwd) "/build/lib:"
+                                      (getenv "PYTHONPATH")))
+               (invoke "pytest")))))))
+    (native-inputs
+     `(("python-pandas" ,python-pandas)  ;; required for test-suite
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
+    (propagated-inputs
+     `(("python-markuppy" ,python-markuppy)
+       ("python-odfpy" ,python-odfpy)
+       ("python-openpyxl" ,python-openpyxl)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-tabulate" ,python-tabulate)
+       ("python-xlrd" ,python-xlrd)
+       ("python-xlwt" ,python-xlwt)))
+    (home-page "https://tablib.readthedocs.io")
+    (synopsis "Format agnostic tabular data library")
+    (description "is a format-agnostic tabular dataset library,
+written in Python.  Supported output formats are Excel (Sets + Books),
+JSON (Sets + Books), YAML (Sets + Books), HTML (Sets), Jira (Sets),
+TSV (Sets), ODS (Sets), CSV (Sets), and DBF (Sets).
+
+@code{tablib} also supports Pandas DataFrames (Sets).  Anyhow, since pandas is
+quite huge, this Guix package doesn't depend on pandas.  In case, just also
+install @code{python-pandas}.")
+    (license license:expat)))