diff mbox series

[bug#50628,154/154] gnu: Add trytond-web-user.

Message ID 86fbb3646b7297c670cf8f2964c224feada6731c.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-web-user): New variable.
---
 gnu/packages/tryton.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1f24277ccb..b500cf3417 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4471,3 +4471,25 @@  provides support of Stripe payment for Vue Storefront integration.")
 shortened.  It also counts the number of times the URL is accessed and
 optionally triggers action.")
     (license license:gpl3+)))
+
+(define-public trytond-web-user
+  (package
+    (name "trytond-web-user")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_web_user" version))
+       (sha256
+        (base32 "1k07d1kcfm2hwwqcyy8k5mjbhhgrnji0hadn487zsx1zp50r6rds"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "web_user"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-web-user")
+    (synopsis "Tryton module to manage Web users")
+    (description "The @emph{Web User} Tryton module provides facilities to
+manage external user accessing from the web.")
+    (license license:gpl3+)))