diff mbox series

[bug#50628,058/154] gnu: Add trytond-customs.

Message ID e59b8a8aa583960a03ff215fb243b1111a22ab2c.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-customs): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3f8920b30f..4f7bd60d12 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1737,6 +1737,31 @@  currency and rate.")
 (define-public python-trytond-currency
   (deprecated-package "python-trytond-currency" trytond-currency))
 
+(define-public trytond-customs
+  (package
+    (name "trytond-customs")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_customs" version))
+       (sha256
+        (base32 "1qilj1b9zr35z15313xbvgklf87dgxddvkcnymklwp9n7vs7hrz5"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "customs"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-simpleeval" ,python-simpleeval)
+       ("trytond" ,trytond)
+       ("trytond-country" ,trytond-country)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-product" ,trytond-product)))
+    (home-page "https://docs.tryton.org/projects/modules-customs")
+    (synopsis "Tryton module for customs")
+    (description "The @emph{Customs} Tryton module allows to define customs
+duty based on the tariff code.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")