diff mbox series

[bug#50628,082/154] gnu: Add trytond-production.

Message ID 47401de610fa0db52a2bed3249c7cb0dc68a87ee.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-production): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 43fa374704..382f814ed1 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2398,6 +2398,30 @@  parent to the price list and the keyword `parent_unit_price` for the formula
 which contains the unit price computed by the parent price list.")
     (license license:gpl3+)))
 
+(define-public trytond-production
+  (package
+    (name "trytond-production")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production" version))
+       (sha256
+        (base32 "0ys1wg52bs3i7yjrrkm9ycn07xz7fsb2pqc4a2bj44691pvrclpk"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-production")
+    (synopsis "Tryton module for production")
+    (description "The @emph{Production} Tryton module defines basics
+for production management: Bill of material and production order.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")