diff mbox series

[bug#50628,089/154] gnu: Add trytond-project-invoice.

Message ID 23b0377e7c4851606c9d9894a4e1673d8d04f689.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-project-invoice): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

M Sept. 18, 2021, 3:09 p.m. UTC | #1
Hartmut Goebel schreef op vr 17-09-2021 om 00:53 [+0200]:
> * gnu/packages/tryton.scm (trytond-project-invoice): New variable.
> ---
>  gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
> index 18f9a7393a..4dd0ef31d3 100644
> --- a/gnu/packages/tryton.scm
> +++ b/gnu/packages/tryton.scm
> @@ -2576,6 +2576,34 @@ enter timesheet for production works.")
>  project and task and the basis for simple project management.")
>      (license license:gpl3+)))
>  
> +(define-public trytond-project-invoice
> +  (package
> +    (name "trytond-project-invoice")
> +    (version "6.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "trytond_project_invoice" version))
> +       (sha256
> +        (base32 "0wxgpsn5kwfz4f51icmc0p7r615lpr286ifwyz0xnd6rrh0glvmw"))))
> +    (build-system python-build-system)
> +    (arguments (tryton-arguments "project_invoice"))
> +    (native-inputs `(,@%standard-trytond-native-inputs))
> +    (propagated-inputs
> +     `(("trytond" ,trytond)
> +       ("trytond-account" ,trytond-account)
> +       ("trytond-account-invoice" ,trytond-account-invoice)
> +       ("trytond-account-product" ,trytond-account-product)
> +       ("trytond-product" ,trytond-product)
> +       ("trytond-project" ,trytond-project)
> +       ("trytond-project-revenue" ,trytond-project-revenue)
> +       ("trytond-timesheet" ,trytond-timesheet)))
> +    (home-page "https://docs.tryton.org/projects/modules-project-invoice")
> +    (synopsis "Tryton module to invoice projects")
> +    (description "The @emph{Project Invoice} Tryton module adds invoice
> +methods on projects.  The methods are:  FIXME")

There is a FIXME here
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 18f9a7393a..4dd0ef31d3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2576,6 +2576,34 @@  enter timesheet for production works.")
 project and task and the basis for simple project management.")
     (license license:gpl3+)))
 
+(define-public trytond-project-invoice
+  (package
+    (name "trytond-project-invoice")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_project_invoice" version))
+       (sha256
+        (base32 "0wxgpsn5kwfz4f51icmc0p7r615lpr286ifwyz0xnd6rrh0glvmw"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "project_invoice"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-account-product" ,trytond-account-product)
+       ("trytond-product" ,trytond-product)
+       ("trytond-project" ,trytond-project)
+       ("trytond-project-revenue" ,trytond-project-revenue)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page "https://docs.tryton.org/projects/modules-project-invoice")
+    (synopsis "Tryton module to invoice projects")
+    (description "The @emph{Project Invoice} Tryton module adds invoice
+methods on projects.  The methods are:  FIXME")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")