diff mbox series

[bug#50628,092/154] gnu: Add trytond-purchase-amendment.

Message ID 8e4e2026a5df4276b4081458106a0a257869df93.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-purchase-amendment): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M Sept. 18, 2021, 3:08 p.m. UTC | #1
Hartmut Goebel schreef op vr 17-09-2021 om 00:53 [+0200]:
> * gnu/packages/tryton.scm (trytond-purchase-amendment): New variable.
> ---
>  gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
> 
> diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
> index 29e197893c..582302ddb6 100644
> --- a/gnu/packages/tryton.scm
> +++ b/gnu/packages/tryton.scm
> @@ -2693,6 +2693,32 @@ the linked time sheets and the linked purchase lines.")
>  (define-public python-trytond-purchase
>    (deprecated-package "python-trytond-purchase" trytond-purchase))
>  
> +(define-public trytond-purchase-amendment
> +  (package
> +    (name "trytond-purchase-amendment")
> +    (version "6.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "trytond_purchase_amendment" version))
> +       (sha256
> +        (base32 "0bgk5ib7y1nzdrfx00g9qr2lxmjkascvh1caps21r12czz0iz5fx"))))
> +    (build-system python-build-system)
> +    (arguments (tryton-arguments "purchase_amendment"))
> +    (native-inputs `(,@%standard-trytond-native-inputs))
> +    (propagated-inputs
> +     `(("trytond" ,trytond)
> +       ("trytond-account-invoice" ,trytond-account-invoice)
> +       ("trytond-purchase" ,trytond-purchase)
> +       ("trytond-purchase-history" ,trytond-purchase-history)
> +       ("trytond-stock" ,trytond-stock)))
> +    (home-page "https://docs.tryton.org/projects/modules-purchase-amendment")
> +    (synopsis "Tryton module to amend purchases")
> +    (description "The @emph{Purchase Amendment} Tryton module allows you to
> +change purchases that are being processed and keep track of the changes.  An
> +amendment is composed of action lines which can:  FIXME")

There is still a FIXME here
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 29e197893c..582302ddb6 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2693,6 +2693,32 @@  the linked time sheets and the linked purchase lines.")
 (define-public python-trytond-purchase
   (deprecated-package "python-trytond-purchase" trytond-purchase))
 
+(define-public trytond-purchase-amendment
+  (package
+    (name "trytond-purchase-amendment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_amendment" version))
+       (sha256
+        (base32 "0bgk5ib7y1nzdrfx00g9qr2lxmjkascvh1caps21r12czz0iz5fx"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_amendment"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-purchase-history" ,trytond-purchase-history)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-purchase-amendment")
+    (synopsis "Tryton module to amend purchases")
+    (description "The @emph{Purchase Amendment} Tryton module allows you to
+change purchases that are being processed and keep track of the changes.  An
+amendment is composed of action lines which can:  FIXME")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase-request
   (package
     (name "trytond-purchase-request")