diff mbox series

[bug#50628,045/154] gnu: Add trytond-analytic-invoice.

Message ID 83ea60f7361a5771ecc436b3d54e58bdd9b43a3b.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-analytic-invoice): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 497a7ad193..f950b9b844 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1311,6 +1311,31 @@  required to analyse accounting using multiple different axes.")
   (deprecated-package
    "python-trytond-analytic-account" trytond-analytic-account))
 
+(define-public trytond-analytic-invoice
+  (package
+    (name "trytond-analytic-invoice")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_invoice" version))
+       (sha256
+        (base32 "151vwcn5sgpqma9kjxbznx4v4wlhfc97dcyb432brxnswf5glcir"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "analytic_invoice"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-account-asset" ,trytond-account-asset)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-analytic-account" ,trytond-analytic-account)))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-invoice")
+    (synopsis "Tryton module to add analytic accounting on invoice")
+    (description "The @emph{Analytic Invoice} Tryton module allows to set
+analytic accounts on invoice line.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")