diff mbox series

[bug#50628,151/154] gnu: Add trytond-web-shop-vue-storefront.

Message ID 1a72eb13b58c54c67aec85f249a77975bf4d7d3f.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-web-shop-vue-storefront): New variable.
---
 gnu/packages/tryton.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 81c92c5a87..d108610e0d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4389,3 +4389,37 @@  user for a period of time only.")
     (description "The @emph{Web Shop} Tryton module facilitates storing
 configuration of an online web shop.")
     (license license:gpl3+)))
+
+(define-public trytond-web-shop-vue-storefront
+  (package
+    (name "trytond-web-shop-vue-storefront")
+    (version "6.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_web_shop_vue_storefront" version))
+       (sha256
+        (base32 "0hccvk5i2qrczvbm66mnp8vcgr9zbnwqmbqmavqlkk7r7bqa1gch"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "web_shop_vue_storefront"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-carrier" ,trytond-carrier)
+       ("trytond-product-attribute" ,trytond-product-attribute)
+       ("trytond-sale-promotion-coupon" ,trytond-sale-promotion-coupon)
+       ("trytond-sale-shipment-cost" ,trytond-sale-shipment-cost)))
+    (propagated-inputs
+     `(("python-elasticsearch" ,python-elasticsearch)
+       ("python-stdnum" ,python-stdnum)
+       ("trytond" ,trytond)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-web-shop" ,trytond-web-shop)
+       ("trytond-web-user" ,trytond-web-user)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-web-shop-vue-storefront")
+    (synopsis "Tryton module to integrate with Vue Storefront")
+    (description "This Tryton module provides the back-end to integrate with
+Vue Storefront 1.x.")
+    (license license:gpl3+)))