diff mbox series

[bug#50628,130/154] gnu: Add trytond-stock-location-move.

Message ID 581e8c94e54597a227588c7bde7dd5ca43cccf9a.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-location-move): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9568d82b0d..bc687f29bc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3793,6 +3793,31 @@  other stock mecanisms to anticipate customer demand.")
 wizard \"Create Inventories\" under the \"Inventories\" sub-menu.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-location-move
+  (package
+    (name "trytond-stock-location-move")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_location_move" version))
+       (sha256
+        (base32 "1mljb97abwcmsl3zmz20b2kfa8wm9q405kr1lag7j5587j2b2h6f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_location_move"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-location-move")
+    (synopsis "Tryton module to move storage locations")
+    (description "The @emph{Stock Location} move Tryton module allows to
+define some Locations as movable
+(like palette).")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")