diff mbox series

[bug#50628,067/154] gnu: Add trytond-notification-email.

Message ID dbe8ae0b20485d88d0c3e47e2b880962e0b708d0.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-notification-email): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 556a32e1f0..5b1a5c69b0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1974,6 +1974,34 @@  that are executed on selected records.")
 mailing lists.")
     (license license:gpl3+)))
 
+(define-public trytond-notification-email
+  (package
+    (name "trytond-notification-email")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_notification_email" version))
+       (sha256
+        (base32 "12hi2p400b15vsmq2a4yifxppc08zdf5l64svv987mxxqv6403ma"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "notification_email"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-commission" ,trytond-commission)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)
+       ("trytond-web-user" ,trytond-web-user)))
+    (propagated-inputs
+     `(("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-notification-email")
+    (synopsis "Tryton module for sending email notifications")
+    (description "The @emph{Notification Email} Tryton module allows to define
+email templates which will be sent to a list of recipients when a trigger is
+fired on a record event.  Extra reports from the same record can be attached
+to the email.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")