diff mbox series

[bug#50628,097/154] gnu: Add trytond-purchase-requisition.

Message ID 622b46d74f2c89b3f5b39cd38975db084cf36136.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-purchase-requisition): New variable.
---
 gnu/packages/tryton.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 20fc780f0d..a3c374e7c6 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2854,6 +2854,37 @@  suppliers.  Each request will collect quotation information from the
 supplier.")
     (license license:gpl3+)))
 
+(define-public trytond-purchase-requisition
+  (package
+    (name "trytond-purchase-requisition")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_requisition" version))
+       (sha256
+        (base32 "0hiz4q4cq7zz6xxl6bkk0vn71hc2wgasnhda5h41cmi69jphhzzk"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_requisition"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-purchase-request" ,trytond-purchase-request)))
+    (home-page "https://docs.tryton.org/projects/modules-purchase-requisition")
+    (synopsis "Tryton module to enter requests for product
+supply (requisition)")
+    (description "The @emph{Purchase Requisition} Tryton module allows users
+to create their requests for product supply (purchase requisitions).  Those
+requisitions will be approved or rejected by the approval group, whoich
+typically is the purchasing department.  On approval, purchase requests will
+be created.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")