diff mbox series

[bug#50628,053/154] gnu: Add trytond-carrier-subdivision.

Message ID cb364209191c32bdbbb2db3e46f86cb95038d4a3.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-carrier-subdivision): New variable.
---
 gnu/packages/tryton.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4472b18305..2e6e2c1036 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1507,6 +1507,41 @@  of carrier.")
 method \"on percentage\" on carrier.")
     (license license:gpl3+)))
 
+(define-public trytond-carrier-subdivision
+  (package
+    (name "trytond-carrier-subdivision")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_carrier_subdivision" version))
+       (sha256
+        (base32 "1mmbz541yywdgm16ij2xfvm50xad24plmqdb739ssg6jj0skmji4"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "carrier_subdivision"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-sale-shipment-cost" ,trytond-sale-shipment-cost)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-carrier" ,trytond-carrier)))
+    (home-page "https://docs.tryton.org/projects/modules-carrier-subdivision")
+    (synopsis "Tryton module that allows carriers selection to be restricted
+by subdivision")
+    (description "The @emph{Carrier Subdivision} Tryton module extends the
+carrier selection pattern with
+
+@itemize
+@item the warehouse Subdivision,
+@item the customer Subdivision,
+@item a regular expression to match against warehouse postal code and
+@item A regular expression to match against customer postal code.
+@end itemize
+
+These can be used to restrict the usage of a carrier to a specific subdivision
+or a specific postal code.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")