diff mbox series

[bug#50628,094/154] gnu: Add trytond-purchase-invoice-line-standalone.

Message ID 2f0db9589a0af793cb28e0678edafd0cd55c3b33.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-purchase-invoice-line-standalone): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e635ee52f5..831681a7ca 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2742,6 +2742,31 @@  historization of the purchase and adds a revision counter which increases each
 time the purchase is reset to draft.")
     (license license:gpl3+)))
 
+(define-public trytond-purchase-invoice-line-standalone
+  (package
+    (name "trytond-purchase-invoice-line-standalone")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_invoice_line_standalone" version))
+       (sha256
+        (base32 "1qwa8a1vxalvb6r3d1w5wwpa9kx7w8c879x1zb4wwc9nqpdji8v0"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_invoice_line_standalone"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice-line-standalone"
+        ,trytond-account-invoice-line-standalone)
+       ("trytond-purchase" ,trytond-purchase)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-purchase-invoice-line-standalone")
+    (synopsis "Tryton module for standalone invoice line from purchase")
+    (description "The @emph{Purchase Invoice Line Standalone} Tryton module
+makes purchase to generate invoice lines instead of invoices.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase-request
   (package
     (name "trytond-purchase-request")