diff mbox series

[bug#50628,114/154] gnu: Add trytond-sale-promotion.

Message ID 69b9edd36bf51dd003b40db407c4f27f70e9fbf2.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-promotion): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 90925d9f77..ea6a2c1a1c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3320,6 +3320,33 @@  price list on sale.  A price list can be set per party or as default.")
 customer's names and codes for products or variants.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-promotion
+  (package
+    (name "trytond-sale-promotion")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_promotion" version))
+       (sha256
+        (base32 "1bvk14sjlqrlg2wakihrcbz8vl40hr6isbc3ijdsv5g1khl3j74i"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_promotion"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-simpleeval" ,python-simpleeval)
+       ("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-product-price-list" ,trytond-product-price-list)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-price-list" ,trytond-sale-price-list)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-promotion")
+    (synopsis "Tryton module for sale promotion")
+    (description "The @emph{Sale Promotion} module allows to apply promotions
+on sale based on criteria.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")