diff mbox series

[bug#50628,113/154] gnu: Add trytond-sale-product-customer.

Message ID 73a20415dbfec88904e120620245e41bc04075f9.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-product-customer): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9c14295248..90925d9f77 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3294,6 +3294,32 @@  payments prior to the creation of any invoice.")
 price list on sale.  A price list can be set per party or as default.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-product-customer
+  (package
+    (name "trytond-sale-product-customer")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_product_customer" version))
+       (sha256
+        (base32 "0yys6mc52v62v51wkg3wngmz9jhqb2lq9v5jvb93j0yh5ah07a4v"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_product_customer"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-sale-amendment" ,trytond-sale-amendment)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-sale-product-customer")
+    (synopsis "Tryton module to manage customer product on sale")
+    (description "The @emph{Sale Product_Customer} Tryton module defines
+customer's names and codes for products or variants.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")