diff mbox series

[bug#50628,021/154] gnu: Add trytond-account-fr.

Message ID 8654836bc52caf8c527ffc612984e63c743e0284.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-fr): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8a15050ad8..f01c87aa1d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -540,6 +540,29 @@  accounting requirements in Europe.  It includes:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public trytond-account-fr
+  (package
+    (name "trytond-account-fr")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_fr" version))
+       (sha256
+        (base32 "1zpzdnd68gsjrz4as019amygdh8yad8wvwrm22dbccwmbbnyvqpg"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_fr"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-party-siret" ,trytond-party-siret)))
+    (home-page "https://docs.tryton.org/projects/modules-account-fr")
+    (synopsis "Tryton module with French chart of accounts")
+    (description "This package provides the French standard chart of account
+for Tryton.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice
   (package
     (name "trytond-account-invoice")