diff mbox series

[bug#50628,142/154] gnu: Add trytond-stock-shipment-measurements.

Message ID a29a39cd226b00756b175ac8df435c534cb52eb3.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-shipment-measurements): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4c4c3f8213..41ce2a32ed 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4131,6 +4131,34 @@  cost on the outgoing moves which is calculated from the carrier purchase
 price.  This cost is added to the product margin reports.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-shipment-measurements
+  (package
+    (name "trytond-stock-shipment-measurements")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_shipment_measurements" version))
+       (sha256
+        (base32 "1h9ijs7yc0013w7cwa4i7ny3dndbgycxxpkai7qw0ygqf9ajmh8c"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_shipment_measurements"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-stock-package" ,trytond-stock-package)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-product-measurements" ,trytond-product-measurements)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-shipment-measurements")
+    (synopsis "Tryton module to add measurements to shipment")
+    (description "The @emph{Stock Shipment Measurements} Tryton module adds
+weight and volume on shipments and packages.  They are computed using the
+measurement and the quantity of their moves.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")