diff mbox series

[bug#50628,037/154] gnu: Add trytond-account-statement-ofx.

Message ID e361eae9c624ad271f67e58ea768379cfba679a7.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-statement-ofx): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7410d4c3d7..0a16fe9d76 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1051,6 +1051,32 @@  the import of @emph{CODA} files as statement.  @emph{CODA} is a standard
 defined by Belgian \"febelfin\".")
     (license license:gpl3+)))
 
+(define-public trytond-account-statement-ofx
+  (package
+    (name "trytond-account-statement-ofx")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_statement_ofx" version))
+       (sha256
+        (base32 "1n24lwp1lfw59xdd7mqaz6ncr5b0bldr2qniqdnkvyaav0h8h5px"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_statement_ofx"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-ofxparse" ,python-ofxparse)
+       ("trytond" ,trytond)
+       ("trytond-account-statement" ,trytond-account-statement)
+       ("trytond-bank" ,trytond-bank)
+       ("trytond-party" ,trytond-party)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-statement-ofx")
+    (synopsis "Tryton module to import OFX statements")
+    (description "The @emph{Account Statement OFX} Tryton module implements
+the import of the @emph{OFX} files as statement.")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")