diff mbox series

[bug#50628,057/154] gnu: Add trytond-company-work-time.

Message ID 7bb55eb3e8b4f0bec334010a3730d5f76864354c.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-company-work-time): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c6e5da81f9..3f8920b30f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1654,6 +1654,33 @@  company and employee and extend the user model.")
 (define-public python-trytond-company
   (deprecated-package "python-trytond-company" trytond-company))
 
+(define-public trytond-company-work-time
+  (package
+    (name "trytond-company-work-time")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_company_work_time" version))
+       (sha256
+        (base32 "0aasp12l66zcys9w3qc4ysi2krd5c9x3xxaxvr29j7zl7nz05bwx"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "company_work_time"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)))
+    (home-page "https://docs.tryton.org/projects/modules-company-work-time")
+    (synopsis "Tryton module to add work time on company")
+    (description "The @emph{Company Work Time} Tryton module adds work time
+management.
+
+The Company Work Time module adds 4 new fields (Hours per Work Day, Hours per
+Work Week, Hours per Work Month, Hours per Work Year) on the company form that
+allow to define how much hours are spent by an employee in a day, a week, a
+month and a year of work.")
+    (license license:gpl3+)))
+
 (define-public trytond-country
   (package
     (name "trytond-country")