diff mbox series

[bug#50628,146/154] gnu: Add trytond-stock-supply-production.

Message ID 5edb814db87d7ee8f5a65d648627285ab8403bce.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-supply-production): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 655b050d30..202ccd29f1 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4261,3 +4261,29 @@  a supplying may happens at any day of the week.")
     (description "The @emph{Stock Supply Forecast} Tryton module takes
 forecast into account to compute purchase requests.")
     (license license:gpl3+)))
+
+(define-public trytond-stock-supply-production
+  (package
+    (name "trytond-stock-supply-production")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_supply_production" version))
+       (sha256
+        (base32 "1qyvj61hwn3xgjqagnr7d28qkiniw5fp0b5vmn9wii9grf7p4m8d"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_supply_production"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-production" ,trytond-production)
+       ("trytond-stock" ,trytond-stock)
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-supply-production")
+    (synopsis "Tryton module for stock supply of production")
+    (description "The @emph{Stock Supply Production} module adds automatic
+supply mechanisms via production request.")
+    (license license:gpl3+)))