diff mbox series

[bug#50628,064/154] gnu: Add trytond-marketing.

Message ID 96af14a3f9d5985ef74ad6334336332b70e013bf.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-marketing): New variable.
---
 gnu/packages/tryton.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4a69384e14..ed9b0745ba 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1901,6 +1901,27 @@  versions of 2010 and 2020.")
 authenticate users via a LDAP server.")
     (license license:gpl3+)))
 
+(define-public trytond-marketing
+  (package
+    (name "trytond-marketing")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_marketing" version))
+       (sha256
+        (base32 "0mh85sx5xj06zjmf9fhcislkwlp7k54fz14k3ia1xxpw5f953y3c"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "marketing"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-marketing")
+    (synopsis "Tryton module to group marketing features")
+    (description "The @emph{Marketing} Tryton module defines the
+fundamentals for marketing modules.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")