diff mbox series

[bug#50628,123/154] gnu: Add trytond-sale-supply.

Message ID f92758b6fa90ea560b62a39d4963e67eec70d7a3.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-supply): New variable.
---
 gnu/packages/tryton.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 86c17fc124..de29dd6d4b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3566,6 +3566,35 @@  services and recurrence rule models.")
 notion of asset to the sale subscription module.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-supply
+  (package
+    (name "trytond-sale-supply")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_supply" version))
+       (sha256
+        (base32 "0lk4pj2fr1q603wnia96i7fzym8pncpvy0hg41q4dkr380nm3qzs"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_supply"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-purchase-request" ,trytond-purchase-request)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-supply")
+    (synopsis "Tryton module for sale supply")
+    (description "The @emph{Sale Supply} Tryton module adds a \"supply on sale
+option\" to purchasable products.  If checked, it will generate a purchase
+request for each sale line of this product regardless of the stock levels.
+Once the purchased products are received they are assigned on the customer
+shipments.  If the purchase is cancelled the sale goes back to the default
+supply method.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")