diff mbox series

[bug#50628,027/154] gnu: Add trytond-account-invoice-secondary-unit.

Message ID b123461abea0da5c174637cd3af2cc53ff383673.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-invoice-secondary-unit): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cef851dce6..0e91b8d864 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -725,6 +725,30 @@  the historization of the invoice and its related fields.")
 allows to create invoice line not linked to an invoice.")
     (license license:gpl3+)))
 
+(define-public trytond-account-invoice-secondary-unit
+  (package
+    (name "trytond-account-invoice-secondary-unit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_invoice_secondary_unit" version))
+       (sha256
+        (base32 "0wam7v92ldajpx3529x2cfvczgwv8ayr6hi6bwj8fi736p9x2kbp"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_invoice_secondary_unit"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-product" ,trytond-product)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-invoice-secondary-unit")
+    (synopsis "Tryton module to add a secondary unit on invoice line")
+    (description "The @emph{Account Invoice Secondary Unit} Tryton module adds
+a secondary unit of measure on invoice line.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice-stock
   (package
     (name "trytond-account-invoice-stock")