diff mbox series

[bug#50628,075/154] gnu: Add trytond-product-cost-history.

Message ID 1da183a0b5221d4314eb0f74f9691926c3d68280.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-product-cost-history): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e9b7c8a984..28adde6eeb 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2217,6 +2217,33 @@  adds the taxonomic classification to the products.")
 first-in-first-out option in the `Cost Method` field of the product form.")
     (license license:gpl3+)))
 
+(define-public trytond-product-cost-history
+  (package
+    (name "trytond-product-cost-history")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_cost_history" version))
+       (sha256
+        (base32 "01cxx1lmcxwangk3q8lhbkd97w208qxpk96mqxv2hgds77xr42cj"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_cost_history"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-product-cost-history")
+    (synopsis "Tryton module to historize product cost")
+    (description "The @emph{Product Cost History} Tryton module adds a `Cost
+History` relate on the product form, showing the cost price evolution of the
+product.  The history is based on the cost price stored on the incoming stock
+moves for goods and assets and based on the history table for service.  When a
+historic cost price is needed, the value is taken from this history for goods
+and assets.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")