diff mbox series

[bug#50628,050/154] gnu: Add trytond-bank.

Message ID bb58321a45757fb98162ce0a1f3da41ff988b492.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-bank): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cb81695412..addaea9fdb 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1433,6 +1433,30 @@  used in the list of authentications in the session section of the
 configuration file.")
     (license license:gpl3+)))
 
+(define-public trytond-bank
+  (package
+    (name "trytond-bank")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_bank" version))
+       (sha256
+        (base32 "0qwgp2s88n4hcqqxg1g34lmmvq5spdlkm978gzn6s96kmmzang0c"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "bank"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-stdnum" ,python-stdnum)
+       ("trytond" ,trytond)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-bank")
+    (synopsis "Tryton module with banks")
+    (description "The @emph{Bank} Tryton module defines the concept of bank
+and account.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")