diff mbox series

[bug#50628,088/154] gnu: Add trytond-project.

Message ID 712f7ed1d95153f6e25d2c40ecc2cb60a4cd5f80.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-project): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 35388eda8f..18f9a7393a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2551,6 +2551,31 @@  work cost.")
 enter timesheet for production works.")
     (license license:gpl3+)))
 
+(define-public trytond-project
+  (package
+    (name "trytond-project")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_project" version))
+       (sha256
+        (base32 "1xlqzg07csr9a89jjgmk5n4d9dd2s3qahg2x8arf3vqqnrqw1g0f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "project"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-company-work-time" ,trytond-company-work-time)
+       ("trytond-party" ,trytond-party)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page "https://docs.tryton.org/projects/modules-project")
+    (synopsis "Tryton module with projects")
+    (description "The @emph{Project} Tryton module provides the concepts of
+project and task and the basis for simple project management.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")