diff mbox series

[bug#50628,043/154] gnu: Add trytond-account-tax-cash.

Message ID ed3be5ff0658447086e0566abe3fd2245f67b4ac.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-tax-cash): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f08fe5fca2..7bfe144299 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1227,6 +1227,30 @@  adds an allocation method based on weight of each line.  The Weight is taken
 from the Product Measurements")
     (license license:gpl3+)))
 
+(define-public trytond-account-tax-cash
+  (package
+    (name "trytond-account-tax-cash")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_tax_cash" version))
+       (sha256
+        (base32 "1di8brrj4jpx99i0553whyh2fddayvwq06dwdshb3iibgv4357cr"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_tax_cash"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-account-tax-cash")
+    (synopsis "Tryton module to support tax report on cash basis")
+    (description "The @emph{Account Tax Cash} Tryton module allows to make tax
+report on cash basis.")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")