diff mbox series

[bug#50628,109/154] gnu: Add trytond-sale-invoice-grouping.

Message ID 060195ed6d88e60d3fd47fdd69f2b2cb6016b2ea.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-invoice-grouping): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 142612864b..12ee4df72f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3189,6 +3189,31 @@  historization of the sale and adds a revision counter which increases each
 time the sale is reset to draft.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-invoice-grouping
+  (package
+    (name "trytond-sale-invoice-grouping")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_invoice_grouping" version))
+       (sha256
+        (base32 "1h8lcm8dg3i6644c50d9y1lca9x7k8l6cvwzkabvzixm54mflqsx"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_invoice_grouping"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-party" ,trytond-party)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-sale-invoice-grouping")
+    (synopsis "Tryton module to group sale invoices")
+    (description "The @emph{Sale Invoice Grouping} Tryton module adds an
+option to define how invoice lines generated from sales will be grouped.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")