diff mbox series

[bug#50628,131/154] gnu: Add trytond-stock-location-sequence.

Message ID 9a2930c981f3c3e239ec477202d5c910ae77a102.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-location-sequence): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index bc687f29bc..401c6268a0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3818,6 +3818,29 @@  define some Locations as movable
 (like palette).")
     (license license:gpl3+)))
 
+(define-public trytond-stock-location-sequence
+  (package
+    (name "trytond-stock-location-sequence")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_location_sequence" version))
+       (sha256
+        (base32 "0lpvgk5s7v30c0hicqc2m6apv8gzd1d6229yv1lrp2g62yp9pa9f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_location_sequence"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-location-sequence")
+    (synopsis "Tryton module to add sequence on location")
+    (description "The @emph{Stock Location Sequence} Tryton module adds
+ordering to location.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")