diff mbox series

[bug#50628,052/154] gnu: Add trytond-carrier-percentage.

Message ID ad6a49743f73e0f8aa5456f2af0080ae06854de9.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-carrier-percentage): New variable.
---
 gnu/packages/tryton.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c42d34b41e..4472b18305 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1481,6 +1481,32 @@  and account.")
 of carrier.")
     (license license:gpl3+)))
 
+(define-public trytond-carrier-percentage
+  (package
+    (name "trytond-carrier-percentage")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_carrier_percentage" version))
+       (sha256
+        (base32 "0glgjf733qliqxbr1sykxn2rlphagnpixhkg84my7bv6cxfmvkh6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "carrier_percentage"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-purchase-shipment-cost" ,trytond-purchase-shipment-cost)
+       ("trytond-sale-shipment-cost" ,trytond-sale-shipment-cost)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-carrier" ,trytond-carrier)
+       ("trytond-currency" ,trytond-currency)))
+    (home-page "https://docs.tryton.org/projects/modules-carrier-percentage")
+    (synopsis "Tryton module to add cost method based on percentage")
+    (description "The @emph{Carrier Percentage} Tryton module adds a cost
+method \"on percentage\" on carrier.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")