diff mbox series

[bug#50628,148/154] gnu: Add trytond-timesheet-cost.

Message ID 3ca8ab966f6204036b3bc257237e818b4fcf7866.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-timesheet-cost): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index db44d325a8..391a5330cb 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4312,3 +4312,27 @@  spent by employees on various works.  This module also comes with several
 reports that show the time spent by employees on works following various time
 periods.")
     (license license:gpl3+)))
+
+(define-public trytond-timesheet-cost
+  (package
+    (name "trytond-timesheet-cost")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_timesheet_cost" version))
+       (sha256
+        (base32 "0pjsdgad2plbx8k6mh6mpa6qbz6lp30nnpv7ydyz0gsgb6jz7li6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "timesheet_cost"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page "https://docs.tryton.org/projects/modules-timesheet-cost")
+    (synopsis "Tryton module to add cost on timesheet")
+    (description "The @emph{Timesheet Cost} Tryton module adds cost price per
+employee.")
+    (license license:gpl3+)))