diff mbox series

[bug#50628,134/154] gnu: Add trytond-stock-package.

Message ID 36958643e719bcb1a5145c2557501a371d58e485.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-package): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 42eb8b8b89..aabd7477fa 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3919,6 +3919,30 @@  it is no more used to compute the forecast quantity of the stock.")
 unit and quantity on stock lot.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-package
+  (package
+    (name "trytond-stock-package")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_package" version))
+       (sha256
+        (base32 "1jbpl141wyc19v27bcyqsph8p2zf9yqprm55yl642mvwq55bshq8"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_package"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-package")
+    (synopsis "Tryton module for stock packaging")
+    (description "The @emph{Stock Package} Tryton module allows to store
+packaging information about customer and supplier return shipments.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")