diff mbox series

[bug#50628,090/154] gnu: Add trytond-project-plan.

Message ID 715a609352c02ec0ea0fe7c0f4f4d6f3f6d40de1.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-project-plan): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4dd0ef31d3..f56a1924ac 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2604,6 +2604,30 @@  project and task and the basis for simple project management.")
 methods on projects.  The methods are:  FIXME")
     (license license:gpl3+)))
 
+(define-public trytond-project-plan
+  (package
+    (name "trytond-project-plan")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_project_plan" version))
+       (sha256
+        (base32 "0yanvfmg4nmbc322h6w9m7asv4bm95y2wksi4rrvlbs84njgvhnq"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "project_plan"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-project" ,trytond-project)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page "https://docs.tryton.org/projects/modules-project-plan")
+    (synopsis "Tryton module to add planning capabilities on projects")
+    (description "The @emph{Project Plan} Tryton module adds planning features
+on top of the Project module.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")