diff mbox series

[bug#50628,115/154] gnu: Add trytond-sale-promotion-coupon.

Message ID 487a5dd28157c535e9bb87a720e3ff1c61c993d1.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-promotion-coupon): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ea6a2c1a1c..3068b8eb05 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3347,6 +3347,30 @@  customer's names and codes for products or variants.")
 on sale based on criteria.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-promotion-coupon
+  (package
+    (name "trytond-sale-promotion-coupon")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_promotion_coupon" version))
+       (sha256
+        (base32 "1hkbsamsf6swx05ij2yh7b3nvmcnlvf9xbz9r7hfs6blx2jkxs3p"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_promotion_coupon"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-sale-promotion" ,trytond-sale-promotion)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-sale-promotion-coupon")
+    (synopsis "Tryton module for sale promotion coupon")
+    (description "The @emph{Sale Promotion Coupon} Tryton module adds coupon
+to the promotions.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")