diff mbox series

[bug#50628,066/154] gnu: Add trytond-marketing-email.

Message ID e818e9a0fa68db30413b3cefe77e914fc5517a58.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-marketing-email): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index a8c562f808..556a32e1f0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1949,6 +1949,31 @@  marketing actions to be automated.  It is based on scenarios and activities
 that are executed on selected records.")
     (license license:gpl3+)))
 
+(define-public trytond-marketing-email
+  (package
+    (name "trytond-marketing-email")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_marketing_email" version))
+       (sha256
+        (base32 "07zh1pni4kpm6bsgyizz0a5k64nyxc9laxxaih9py7d24p9pgvky"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "marketing_email"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-marketing" ,trytond-marketing)
+       ("trytond-party" ,trytond-party)
+       ("trytond-web-shortener" ,trytond-web-shortener)
+       ("trytond-web-user" ,trytond-web-user)))
+    (home-page "https://docs.tryton.org/projects/modules-marketing-email")
+    (synopsis "Tryton module to manage marketing mailing lists")
+    (description "This package provides a Tryton module for managing marketing
+mailing lists.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")