diff mbox series

[bug#50628,120/154] gnu: Add trytond-sale-stock-quantity.

Message ID 85fb8b2a0da66610e3fbefd353c479b0fb6d325a.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-stock-quantity): New variable.
---
 gnu/packages/tryton.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index b237f6b9c7..de53e118e9 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3486,6 +3486,35 @@  line is over shipped more than the tolerance percentage, then a warning is
 raised.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-stock-quantity
+  (package
+    (name "trytond-sale-stock-quantity")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_stock_quantity" version))
+       (sha256
+        (base32 "0xi79nmizly3hfc1ppcid622nvby50524jflisfvmjb651ixpfl8"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_stock_quantity"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-stock-quantity")
+    (synopsis "Tryton module to add stock warning on sale")
+    (description "The @emph{Sale Stock Quantity} Tryton module checks the
+stock quantity of the products when quoting a sale.  The check will warn the
+user if the forecast quantity at the sale date (and further dates until next
+supply) is lower than the quantity sold by considering other sales and the
+stock forecasts.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")