diff mbox series

[bug#50628,042/154] gnu: Add trytond-account-stock-landed-cost-weight.

Message ID f983dfcf686515e8c9847d7f4491bac47418d291.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-stock-landed-cost-weight): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 81c00d81e6..f08fe5fca2 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1199,6 +1199,34 @@  continental accounting model for stock valuation.")
 allocate landed cost on Supplier Shipments after their reception.")
     (license license:gpl3+)))
 
+(define-public trytond-account-stock-landed-cost-weight
+  (package
+    (name "trytond-account-stock-landed-cost-weight")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_stock_landed_cost_weight" version))
+       (sha256
+        (base32 "10i0ww3k2cgdg227lv6h8ag2j6rm07maylbh3n0grwxfy8dbq34m"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_stock_landed_cost_weight"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-stock-landed-cost" ,trytond-account-stock-landed-cost)
+       ("trytond-product" ,trytond-product)
+       ("trytond-product-measurements" ,trytond-product-measurements)
+       ("trytond-stock-shipment-measurements"
+        ,trytond-stock-shipment-measurements)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-stock-landed-cost-weight")
+    (synopsis "Tryton module for landed cost per weight")
+    (description "The @emph{Account Stock Landed Cost Weight} Tryton module
+adds an allocation method based on weight of each line.  The Weight is taken
+from the Product Measurements")
+    (license license:gpl3+)))
+
 (define-public trytond-analytic-account
   (package
     (name "trytond-analytic-account")