diff mbox series

[bug#50628,072/154] gnu: Add trytond-product-classification.

Message ID b7a8643a76f9f85c5ed545df48c6694a11f9e5a7.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-product-classification): New variable.
---
 gnu/packages/tryton.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7d8d015077..dd8b6d51fc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2147,6 +2147,30 @@  Template and Product.")
 models `Attribute` and `Attribute Set` for products.")
     (license license:gpl3+)))
 
+(define-public trytond-product-classification
+  (package
+    (name "trytond-product-classification")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_classification" version))
+       (sha256
+        (base32 "1sq42siqq8w6dd8jnqnkzy3npaf9g2nrdzazkl6nw5dysvpsz8cr"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_classification"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-product-classification")
+    (synopsis "Tryton module to implement product classification")
+    (description "The @emph{Product Classification} Tryton module defines the
+tools for other modules to create classifications of products.  It adds a
+reference field classification to the product template.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")