diff mbox series

[bug#50628,063/154] gnu: Add trytond-ldap-authentication.

Message ID dc06b0a3e9fde3b7387a8be41ebf239a3329f5d6.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-ldap-authentication): New variable.
---
 gnu/packages/tryton.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1bc1b9fb2c..4a69384e14 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1879,6 +1879,28 @@  Incoterms on sales, purchases and shipments.  The module contains the Incoterm
 versions of 2010 and 2020.")
     (license license:gpl3+)))
 
+(define-public trytond-ldap-authentication
+  (package
+    (name "trytond-ldap-authentication")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_ldap_authentication" version))
+       (sha256
+        (base32 "1iylbpp66qjff1mkp0w3a703pracpcv3bv25i2bafkmcjiv9b4jl"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "ldap_authentication"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-ldap3" ,python-ldap3)
+       ("trytond" ,trytond)))
+    (home-page "https://docs.tryton.org/projects/modules-ldap-authentication")
+    (synopsis "Tryton module to authenticate users through LDAP")
+    (description "The @emph{LDAP Authentication} Tryton module allows to
+authenticate users via a LDAP server.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")