diff mbox series

[bug#50628,128/154] gnu: Add trytond-stock-forecast.

Message ID b64929d1c01e5fd1cf7b20bea05fa3864ae75f4f.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-forecast): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index dece7f7716..d5e1d7b331 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3743,6 +3743,31 @@  location to pick products.")
 consignment stock from supplier or at customer warehouse.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-forecast
+  (package
+    (name "trytond-stock-forecast")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_forecast" version))
+       (sha256
+        (base32 "1l3ks2jbz95qqbv9jsvakrxgazyq1kkk3fspwvrg1d10rv6xmb58"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_forecast"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-forecast")
+    (synopsis "Tryton module with stock forecasts")
+    (description "The @emph{Stock Forecast} Tryton module provide a simple way
+to create stock moves toward customers with a date in the future.  This allows
+other stock mecanisms to anticipate customer demand.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")