diff mbox series

[bug#50628,073/154] gnu: Add trytond-product-classification-taxonomic.

Message ID d74ae5a30a08c569512182b8ddc5aaf8baa975b5.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-product-classification-taxonomic): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index dd8b6d51fc..36bbecf976 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2171,6 +2171,29 @@  tools for other modules to create classifications of products.  It adds a
 reference field classification to the product template.")
     (license license:gpl3+)))
 
+(define-public trytond-product-classification-taxonomic
+  (package
+    (name "trytond-product-classification-taxonomic")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_classification_taxonomic" version))
+       (sha256
+        (base32 "1pkk0z4bl1pz2yxs46b18fj35zwa80dnbickjg1ad66n9yrmifk6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_classification_taxonomic"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product-classification" ,trytond-product-classification)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-product-classification-taxonomic")
+    (synopsis "Tryton module to implement product classification taxonomic")
+    (description "The @emph{Product Classification Taxonomic} Tryton module
+adds the taxonomic classification to the products.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")