diff mbox series

[bug#50628,029/154] gnu: Add trytond-account-payment-braintree.

Message ID c6955da1f6307e87af547c2e9ee58bc52ab3e2b3.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-payment-braintree): New variable.
---
 gnu/packages/tryton.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index db7f46f019..191ca0b9e3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -806,6 +806,34 @@  average price of the posted invoice lines that are linked to it.")
 payments for receivable or payable Account Move Lines.")
     (license license:gpl3+)))
 
+(define-public trytond-account-payment-braintree
+  (package
+    (name "trytond-account-payment-braintree")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_payment_braintree" version))
+       (sha256
+        (base32 "0dgw47q4m5l13bhfl1kdpajh0q94pazdrq9sqzf1vg9mggai2gvi"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_payment_braintree"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-braintree" ,python-braintree)
+       ("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-payment" ,trytond-account-payment)
+       ("trytond-party" ,trytond-party)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-payment-braintree")
+    (synopsis "Tryton module for Braintree payment")
+    (description "The @emph{Account Payment Braintree} Tryton module allows
+receipt of payments using Braintree.  It uses the Drop-in UI in a checkout
+form to handle the payment method nonce for card and other supported payment
+methods.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-product
   (package
     (name "trytond-account-product")