diff mbox series

[bug#50628,078/154] gnu: Add trytond-product-measurements.

Message ID e3a542a4c74c8e5730e640bff33d39b7510f808e.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-product-measurements): New variable.
---
 gnu/packages/tryton.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c2d8f616c9..fb22bdfe96 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2303,6 +2303,28 @@  components to products.  This enables a defined set of products to be sold or
 purchased using a single line.")
     (license license:gpl3+)))
 
+(define-public trytond-product-measurements
+  (package
+    (name "trytond-product-measurements")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_measurements" version))
+       (sha256
+        (base32 "0za3p0wxh2kb6f49455pggnpmy0vfiwj95j5c3l63x8q5yp8vdjl"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_measurements"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)))
+    (home-page "https://docs.tryton.org/projects/modules-product-measurements")
+    (synopsis "Tryton module to add measurements to product")
+    (description "The @emph{Product Measurements} Tryton module adds this
+following measurements to Product:")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")