diff mbox series

[bug#50628,085/154] gnu: Add trytond-production-split.

Message ID 8dc70d0d26ab715f52f50e1a1d28623ba031e4da.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-production-split): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e787951718..9d497776e7 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2474,6 +2474,31 @@  the production.")
 routings for production: Routing, Step and Operation.")
     (license license:gpl3+)))
 
+(define-public trytond-production-split
+  (package
+    (name "trytond-production-split")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production_split" version))
+       (sha256
+        (base32 "0jl2jnm0lwybwjw2w4nb7ih2s3z7lp00l6zm5vsx4phcvfvzcxgi"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production_split"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production" ,trytond-production)))
+    (home-page "https://docs.tryton.org/projects/modules-production-split")
+    (synopsis "Tryton module to split production")
+    (description "The @emph{Production Split} Tryton module adds on the
+production a wizard that allows to split it.  The production is split into
+productions of Quantity.  If a count is set, it will be split only this number
+of times.  On occasion there can be a production with the remaining
+quantity.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")