diff mbox series

[bug#50628,126/154] gnu: Add trytond-stock-assign-manual.

Message ID 7b1c60fbdef77a15d8397e75326af440953df832.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-assign-manual): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c366f2cefd..3e466000f6 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3687,6 +3687,31 @@  inventory to control and update stock levels.")
 (define-public python-trytond-stock
   (deprecated-package "python-trytond-stock" trytond-stock))
 
+(define-public trytond-stock-assign-manual
+  (package
+    (name "trytond-stock-assign-manual")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_assign_manual" version))
+       (sha256
+        (base32 "0106x21ncxiyd4jsbdapmf6gfix6infjf59807j2lqmrblb3z25f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_assign_manual"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-production" ,trytond-production)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-assign-manual")
+    (synopsis "Tryton module to assign manually stock move")
+    (description "The @emph{Stock Assign Manual} Tryton module adds a wizard
+on shipments and production that allows you to decide from which precise
+location to pick products.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-lot
   (package
     (name "trytond-stock-lot")