diff mbox series

[bug#50628,103/154] gnu: Add trytond-sale-complaint.

Message ID 51cb811d11051fdefc4a95f55a2bf99f9380607f.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-sale-complaint): New variable.
---
 gnu/packages/tryton.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 4669538fd4..2b0d9e571a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3038,6 +3038,31 @@  sales that are being processed and keep track of the changes.  An amendment is
 composed of action lines which can:")
     (license license:gpl3+)))
 
+(define-public trytond-sale-complaint
+  (package
+    (name "trytond-sale-complaint")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_complaint" version))
+       (sha256
+        (base32 "0wbs7kawrzz39z0jw34ygdb85qja49xfb75ahbwgqd185wf3jvgz"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_complaint"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-complaint")
+    (synopsis "Tryton module for sale complaints")
+    (description "The @emph{Sale Complaint} Tryton module defines the
+@code{Complaint} model.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")