diff mbox series

[bug#50628,140/154] gnu: Add trytond-stock-secondary-unit.

Message ID 5575e70d79b0878bfee7bcf1a2258c74f2cf1081.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:54 p.m. UTC
* gnu/packages/tryton.scm (trytond-stock-secondary-unit): New variable.
---
 gnu/packages/tryton.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index b6887cd234..e2fedbf108 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4084,6 +4084,29 @@  reducing stock level by proposing to consume earlier.")
 stock quantity issues.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-secondary-unit
+  (package
+    (name "trytond-stock-secondary-unit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_secondary_unit" version))
+       (sha256
+        (base32 "0s4nryiirdbndm2sz5aqpk2mzw9zxah92gmh6433sj5zyc6a22if"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_secondary_unit"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-secondary-unit")
+    (synopsis "Tryton module to add a secondary unit on stock move")
+    (description "The @emph{Stock Secondary Unit} Tryton module adds a
+secondary unit of measure on the stock move.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")