diff mbox series

[bug#50628,033/154] gnu: Add trytond-account-payment-stripe.

Message ID 3a27ce8c71287538303fb9045e4c4ead59ec6661.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:52 p.m. UTC
* gnu/packages/tryton.scm (trytond-account-payment-stripe): New variable.
---
 gnu/packages/tryton.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 282d1cbc51..09c3e57f02 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -915,6 +915,33 @@  generate SEPA files for a Payment Group.")
 CFONB flavors to SEPA messages.")
     (license license:gpl3+)))
 
+(define-public trytond-account-payment-stripe
+  (package
+    (name "trytond-account-payment-stripe")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_payment_stripe" version))
+       (sha256
+        (base32 "18hr2lrrx9asb0d3cjcpska4bv825yjln9cbqjzg0xbl36z6w3s2"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_payment_stripe"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("python-stripe" ,python-stripe)
+       ("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-payment" ,trytond-account-payment)
+       ("trytond-party" ,trytond-party)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-account-payment-stripe")
+    (synopsis "Tryton module for Stripe payment")
+    (description "The @emph{Account Payment Stripe} Tryton module for
+receiving payments from Stripe.  It uses Stripe.js and Stripe Elements in a
+checkout form to handle Setup Intent and Payment Intent by card.")
+    (license license:gpl3+)))
+
 (define-public trytond-account-product
   (package
     (name "trytond-account-product")