diff mbox series

[bug#50628,060/154] gnu: Add trytond-edocument-uncefact.

Message ID 058cd7696526c47c1fc8c274d00a04ef953cc271.1631832505.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add 146 Tryton modules and some dependencies | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 16, 2021, 10:53 p.m. UTC
* gnu/packages/tryton.scm (trytond-edocument-uncefact): New variable.
---
 gnu/packages/tryton.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index aea203cd8c..ed58ffb233 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1783,6 +1783,35 @@  duty based on the tariff code.")
 configure their dashboard.")
     (license license:gpl3+)))
 
+(define-public trytond-edocument-uncefact
+  (package
+    (name "trytond-edocument-uncefact")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_edocument_uncefact" version))
+       (sha256
+        (base32 "0b5qhkirfkrh5g1d7m42f7niiz86favf352i403fdi4j532sl3i2"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "edocument_uncefact"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("python-lxml" ,python-lxml)
+       ("trytond-account-invoice" ,trytond-account-invoice)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-edocument-unece" ,trytond-edocument-unece)))
+    (home-page "https://docs.tryton.org/projects/modules-edocument-uncefact")
+    (synopsis "Tryton module for electronic document UN/CEFACT")
+    (description "The @emph{Edocument UN/CEFACT} Tryton module implements
+electronic document from UN/CEFACT.  Supported formats are:
+
+@itemize
+@item Cross-Industry-Invoice (16B-CII)
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")